PHP Requirements

From the UNA Wiki, we see: Requirements

  • PHP 5.6 (5.5.10 before 10.0.0-B1, 5.5.0 before 9.0.0-RC7)

This looks outdated. What is the best PHP version for UNA 12.1?

Thank you

  • 864
  • More
Replies (14)
    • Hello @banister !

      For UNA 12.x it is fine to have PHP 7.x. UNA 13 Beta 2 requires to have PHP 7.4.

      • Hi @banister, Yes, as @LeonidS said UNA 12.1.0 works well with PHP 7.4. I am running it with that PHP version. I have never tested it with PHP 8.1. Instead I am planning to run UNA 13 with 8.1 as they have fixed many PHP 8 compatibility issues.

        • The latest requirements info can be found here . I noticed some time ago, that there is an old requirements page available, with the information you mentioned, as well. Maybe it has been removed meanwhile.

          • @OneEagle I did the same too (based on your kind guidance). I have two sites running on php.8.1 and running well (apart from minor issues that every now and then post them here!). However, I would like to make the following observations in this context (i.e., compatibility of php8.1.8 with the requirements) which I don't know if they really matter or not (I am still learning the robes 😀). I will post the summary first and details at the bottom for in depth review by the experts/masters.

            1.compared to the list of requirements listed in this link ( ) (all for php7.4) the following are missing in the php8.1.8:

            -openssl, exif, json, fileinfo

            2.When I tried to install them I couldn't install any of them, responses are given below. Some of them there is a message indicate, there is possibly a newer version (? not sure about that), but for json (it was a different message).

            3.My question is do we need to do something different to address those "missing" components (especially json) or not.

            I appreciate all the help.

            @LeonidS @thomlin


            A-My current php.8.1 version:


            B-Current library of php-components: (missing -openssl, exif, json, fileinfo)



            C-Response to trying to install php8.1 json:


            D-Response to trying to install other "missing" components:


              • Hi @Tajrebatee Thanks for pointing that out. Since PHP version 8, those modules or some of them have been moved into the core code and are no longer available as separate modules. Therefore, you don't need to install them separately. If your PHP was installed correctly, you should be fine. @Alex T⚜️ and @LeonidS , please correct me if I'am wrong. Also you can find out with your hosting provider.

                BTW, are you having some PHP 8.x compatibility issues with your 13-Bx site? Which ones?

                Yes, those server requirements found on that WIki page (github) definitely need to be updated.


                • @OneEagle Thank you so much for your prompt and comprehensive reply.

                  Overall, php 8.1.8 (the one I have) runs smoothly, with few exception here and there, which I am not sure if they due to the php version or some other issues with UNA, that's why I keep posting and asking them. What is the definition of "compatibility issues"? any particular test I need to do on my sites to pick those up? tnx

                  • Yes, 7.4.30 will be EOL November 2022. However, don't get too excited about this; you should be OK until support for 8.1 comes along. You won't get hacked come December. However, the perfect time to try and find exploits is when something goes EOL because it won't be fixed.

                    • PHP 7.4 End of Life/Security Support End Date (community)

                      November 28, 2022.

                      Zend PHP 7.4 LTS End Date (with help from Zend)

                      December 2026.

                      If you're using Ubuntu + Virtualmin, I bet you they will not be ready for 22.04 upgrade before then. I wouldn't freak out anyway because I expect 3 more years of support for LTS anyway.

                      • This discussion is just what I was looking for to resolve my questions on the "Requirement" for "PHP 7.4."

                        Thanks, guys, for speaking in detail to the use of PHP 8.x with later versions of UNA. I think the best way for UNA to word the PHP requirement in the future is to say, for example: "minimum requirement for UNA 13.x version is PHP 7.4" or whatever the appropriate version and minimum requirement is at that time. Subsequently, if there are any caveats regarding the use of higher PHP versions than the minimum, these can be addressed separately in a blog used by UNA for updates/bug-fixes/etc. As of this date (mid-2023), we are well beyond the EOL for 7.4.

                        Hackers look for low-hanging fruit; that is, they look for known vulnerabilities in outdated software. And while developers may issue patches or otherwise fix the older version for a while, it's good practice to install the latest stable version of perl, php, and python (along with associated modules, in case they have been updated, too), then test, test, test existing scripts and pages.


                        • Hello @TUna88

                          We have the detailed requirements here

                          • Thank you, Leonid. Yes, I had seen them and wondered if 7.4 was a minimum and if others had successfully used 8 with the new release. I appreciate you.

                            • On my server there is a check list to use a module, but if you do not see it, look at the PHP configuration file and see if it is listed and turn it on there. Then go back to the check list.

                              • 8x fine work

                                Login or Join to comment.